Rosserial+arduino nano (168)=error lost sync

Rosserial+arduino nano (168)=error lost sync

Сообщение belyaevas » 17 окт 2012, 18:09

Вообщем проблема в заголовке
ubuntu 11.10+Ros electric +adrduino ide 1.0.1
заливаю скетч примера ServoControl
roscore
rosrun rosserial_python serial_node.py /dev/ttyUSB0
rostopic pub servo std_msgs/UInt16 60
Lost sync with device, restarting...
Lost sync with device, restarting...
Lost sync with device, restarting...
файл Ros.h пытался изменить
typedef NodeHandle_<ArduinoHardware, 4, 4, 64, 64> NodeHandle;
значения применял разные, нигде нетподробной информации неделя поисков и мучениий
просьба помочь кто чем!
Мы не приближаем "терминатора" мы к нему готовимся!
I'm Robomaster.
belyaevas
 
Сообщения: 5
Зарегистрирован: 11 янв 2012, 17:37
Откуда: Krasnoyarsk
programming: basic

Re: Rosserial+arduino nano (168)=error lost sync

Сообщение noonv » 18 окт 2012, 06:26

а тестовый скетч Hello World работает?
Аватара пользователя
noonv
Администратор
 
Сообщения: 557
Зарегистрирован: 05 май 2011, 15:44
Откуда: Калининград
programming: С++

Re: Rosserial+arduino nano (168)=error lost sync

Сообщение belyaevas » 19 окт 2012, 17:35

да работает остальное все логает даже blink
Мы не приближаем "терминатора" мы к нему готовимся!
I'm Robomaster.
belyaevas
 
Сообщения: 5
Зарегистрирован: 11 янв 2012, 17:37
Откуда: Krasnoyarsk
programming: basic


Вернуться в Программирование

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron
© 2009-2019 |  О проекте  |  Политика Конфиденциальности  |